debconf unable to initialize frontend Dialog

debconf: unable to initialize frontend: Dialog

Posted on

debconf: unable to initialize frontend: Dialog – Saat saya akan melakukan pengecakan update package-package pada sistem operasi Ubuntu 20.04 milik saya melalui perintah apt update, ada notifikasi error yang cukup mengganggu mata saya pada saat akhir proses update yaitu :

debconf: unable to initialize frontend: Dialog
debconf: (No usable dialog-like program is installed, so the dialog based fro ntend cannot be used. at /usr/share/perl5/Debconf/FrontEnd/Dialog.pm line 76. )
debconf: falling back to frontend: Readline

Untuk mengatasi hal error seperti ini saya hanya perlu menginstall package dialog nya saja melalui perintah.

$ sudo apt install dialog -y
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
dialog
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 231 kB of archives.
After this operation, 1227 kB of additional disk space will be used.
Get:1 http://ap-melbourne-1-ad-1.clouds.archive.ubuntu.com/ubuntu focal/universe amd64 dialog amd64 1.3-20190808-1 [231 kB]
Fetched 231 kB in 2s (102 kB/s)
debconf: delaying package configuration, since apt-utils is not installed
Selecting previously unselected package dialog.
(Reading database ... 135786 files and directories currently installed.)
Preparing to unpack .../dialog_1.3-20190808-1_amd64.deb ...
Unpacking dialog (1.3-20190808-1) ...
Setting up dialog (1.3-20190808-1) ...

Selanjutnya saat menjalankan perintah apt update pun sudah tidak ada lagi notif error seperti diatas, selamat mencoba.

Leave a Reply

Your email address will not be published.